EOL CentOS 5.x

Update of packages using default repositories (base, update etc.) is no longer applicable as centos.org has stopped the support of CentOS 5.x.. You should switch boxes, run on CentOS 5.x., to so called Vault repositories. At least it will give a possibility to install packages, which are necessary because of different dependencies.

To switch to Vault repository:

  1. Disable base, updates and other enabled repositories (where enabled=1 is set) in the CentOS-Base.repo:

    # sed -i 's/enabled=1/enabled=0/g' /etc/yum.repos.d/CentOS-Base.repo

    Then check the /etc/yum.repos.d/CentOS-Base.repo, and upend 'enabled=0' into every repository with no 'enabled' option.

  2. Enable c5.11-base and c5.11-updates:

    #vim  /etc/yum.repos.d/CentOS-Vault.repo
  3. Append to the file or edit if exists (set enabled=1) c5.11-base and c5.11-updates repositories:

    [c5.11-base]
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
    gpgcheck=1
    name=CentOS-5.11 - Base
    baseurl=http://vault.centos.org/5.11/os/$basearch/
    exclude=ruby* libyaml* corosync* corosynclib* pacemaker*
    enabled=1
    [c5.11-updates]
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
    gpgcheck=1
    name=CentOS-5.11 - Updates
    baseurl=http://vault.centos.org/5.11/updates/$basearch/
    exclude=ruby* libyaml* corosync* corosynclib* pacemaker*
    enabled=1